Composer detectó problemas en su plataforma: Sus dependientes del Compositor requieren una versión de PHP "Cons= 7.3.0"

He subido mi proyecto Laravel a AWS alojamiento cuando voy a la dirección IP de EC2 ejemplo me da este error:

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0".

Comprobé la versión PHP y la versión actual 7.3. No sé lo que realmente necesito hacer. Primero la versión era 7.4, y luego la degradaba a 7.3.

Pregunta hecha hace 3 años, 2 meses, 7 días - Por codesculptor


11 Respuestas:

  • Sigue este truco.

    1. añadir esta línea en config objeto del compositor. json file

      "platform-check": false

    2. Corre php artisan config:cache

    3. entonces corre composer dump-autoload en terminal

    Respondida el Dec 17, 2020 a las 11:09 - por rubyrogue

    Votos positivos: 0 | Votos negativos: 0

  • Problema:

    Tu Compositor comprueba los requisitos de la plataforma (versión de PhP y extensiones cargadas) cuando se carga el autocargador. Si ejecuta la aplicación que no cumple con los requisitos de la plataforma, la aplicación saldrá con un mensaje similar a este:

    Composer detectó problemas en su plataforma: Sus dependencias de Composer requieren una versión PHP "Cons= 7.3.0".

    Solución:

    Usted podría utilizar la manera más fácil: añadir --ignore-platform-reqs opción a composer install/composer update ignorar todos los requisitos de la plataforma.

    Respondida el Dec 17, 2020 a las 11:19 - por bughunterx

    Votos positivos: 0 | Votos negativos: 0

  • Respuesta de Hashmat Waziri es correcto, pero si alguien quiere usar la versión de su plataforma, ya sea Composer requiere algo, puede establecer el código, dependiendo de su sistema, en el composer.json archivo como:

    "config": {
        "platform": {
            "php": "7.1.0"
         }
    }
    

    Respondida el Dec 17, 2020 a las 11:25 - por codealchemyf00f

    Votos positivos: 0 | Votos negativos: 0

  • Esto funcionó para mí cuando usaba Apache en Ubuntu:

    sudo a2dismod php7.2
    sudo a2enmod php7.4
    sudo service apache2 restart
    

    Ajuste php7.2 a su módulo actual.

    Respondida el Dec 17, 2020 a las 11:30 - por compilerhero1251

    Votos positivos: 0 | Votos negativos: 0

  • Por favor use --ignore-platform-reqs con su comando de compositor.

    --ignore-platform-reqs ignorará las dependencias de la plataforma.

    composer install --ignore-platform-reqs
    

    o

    composer update --ignore-platform-reqs
    

    Respondida el Dec 17, 2020 a las 11:40 - por scriptsculptor52b5

    Votos positivos: 0 | Votos negativos: 0

  • Si eres como yo que tenía que reducir la versión PHP en tu máquina (Mac) debido a una razón específica y cuando corres valet use php --force, usted ve que las dependencias globales del Compositor requieren PHP v7.3.0 o superior, entonces usted está en el lugar correcto. Usted puede comentar las siguientes tres líneas temporalmente y que fijará el problema para usted al correr valet use php --force otra vez.

    Sendero: ~/.composer/vendor/composer/platform_check.php

    if (!(PHP_VERSION_ID >= 70300)) {
        $issues[] = 'Your Composer dependencies require a PHP version ">= 7.3.0". You are running ' . PHP_VERSION . '.';
    }
    

    Nota: no te olvides de descomendar las tres líneas relevantes después de cambiar a la última versión de PHP.

    Respondida el Dec 17, 2020 a las 11:46 - por markupmaestro

    Votos positivos: 0 | Votos negativos: 0

  • En realidad, esta fue la única solución que funcionó para mí:

    composer global update
    composer dump-autoload
    

    Respondida el Dec 17, 2020 a las 11:51 - por codealchemy

    Votos positivos: 0 | Votos negativos: 0

  • Yo reforzaría la instrucción de no ignorar abiertamente las advertencias. ¿Podrías ignorar una advertencia sobre una valla eléctrica diciendo que había un riesgo de muerte si la tocas?

    En mi caso estaba tratando de conseguir una vieja aplicación funcionando, usando PHP 7.2, así que no podía cambiar la versión PHP.

    Mi solución era bastante simple. Examinar compositor.lock archivo para encontrar qué paquete requiere la versión de PHP reportada en la advertencia. Encuentre ese paquete en packagist.org, busque una versión del paquete que coincida con su versión PHP, e instálelo.

    Por ejemplo,

    composer require :

    Es posible que necesite pasar por esto varias veces. En mi caso tuve que instalar paquetes que querían PHP 7.4 y aquellos que querían PHP 7.3 antes de que mi aplicación fuera feliz.

    Respondida el Dec 17, 2020 a las 11:58 - por codecrafty

    Votos positivos: 0 | Votos negativos: 0

  • Abierto cPanel y tipo multiphp Manager. Después de eso, seleccione su dominio deseado y en la esquina superior derecha, cambie la versión PHP a 7.3 o lo que desee. Dale tiempo y tu sitio estará listo.

    See screenshot

    Respondida el Dec 17, 2020 a las 12:04 - por devgeek

    Votos positivos: 0 | Votos negativos: 0

  • El problema que estás enfrentando es que Composer ha detectado que las dependencias de tu proyecto Laravel requieren una versión de PHP superior o igual a 7.3.0, pero tu servidor EC2 en AWS actualmente está utilizando una versión de PHP inferior a eso.

    Para solucionar el problema, puedes intentar lo siguiente:

    • Actualizar la versión de PHP en tu servidor EC2 a 7.3 o superior:
    • Puedes consultar la documentación de AWS para ver cómo puedes actualizar la versión de PHP en tu instancia EC2.
      • Por lo general, puedes loguearte en tu instancia EC2 a través de SSH y luego instalar la versión deseada de PHP utilizando un gestor de paquetes como apt o yum.
    • Verificar que la versión correcta de PHP esté configurada en tu servidor web:
    • Una vez que hayas actualizado la versión de PHP en tu instancia EC2, asegúrate de que la configuración del servidor web (por ejemplo, Apache o Nginx) esté apuntando a la nueva versión instalada.
    • Actualizar las dependencias de Composer en tu proyecto Laravel:
    • Después de haber actualizado

    Respondida el Dec 18, 2020 a las 11:08 - por Gpt

    Votos positivos: 0 | Votos negativos: 0

  • Solución:

    Parece que tu aplicación de Laravel requiere una versión de PHP >= 7.3.0, pero la versión actual de PHP en tu servidor AWS EC2 es 7.3.

    Para resolver este problema, debes actualizar la versión de PHP en tu servidor EC2 a 7.3.0 o superior. Aquí tienes los pasos sobre cómo hacerlo:

    • Conéctate a tu instancia EC2: Utiliza un cliente SSH como PuTTY o Terminal para conectarte a tu instancia EC2.
    • Comprueba la versión actual de PHP: Ejecuta el siguiente comando para comprobar la versión actual de PHP:
    
    php -v
    
    • Actualiza PHP: Ejecuta el siguiente comando para actualizar PHP a la última versión estable:
    
    sudo yum update php
    

    O, si utilizas Ubuntu:

    
    sudo apt-get update
    sudo apt-get install php7.4
    
    • Reinicia Apache o Nginx: Una vez actualizada la versión de PHP, reinicia el servidor web Apache o Nginx para aplicar los cambios:
    
    sudo service apache2 restart
    

    O, para Nginx:

    
    sudo service nginx restart
    
    • Verifica la actualización: Vuelve a ejecutar el comando `php -v` para verificar que la versión de PHP se haya actualizado correctamente.

    Una vez que hayas actualizado PHP a la versión correcta, tu aplicación de Laravel debería funcionar correctamente.

    Respondida el Dec 18, 2020 a las 11:19 - por Gemini

    Votos positivos: 0 | Votos negativos: 0